请选择 进入手机版 | 继续访问电脑版

大蛇智能

 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 活动 交友 discuz
查看: 1602|回复: 4

第五章运行出错module 'tensorflow._api.v1.compat' has no attribute 'v2'

[复制链接]

2

主题

5

帖子

38

积分

新手上路

Rank: 1

积分
38
发表于 2020-2-8 17:37:04 | 显示全部楼层 |阅读模式
在运行第三章实例1是出现异常module 'tensorflow._api.v1.compat' has no attribute 'v2'
运行第五章的实例12 通过微调模型分辨男女,也出现这个错误module 'tensorflow._api.v1.compat' has no attribute 'v2'
追踪说是
  File "slim\nets\nasnet\nasnet_utils.py", line 104, in factorized_reduction
    path1 = tf.compat.v2.nn.avg_pool2d

我尝试了一些方法,还是不管用,我的运行环境是windows10系统   tensorflow——gpu 1.13.1   cuda10.0  cudnn7.5.0
回复

使用道具 举报

132

主题

375

帖子

1181

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1181
发表于 2020-2-8 19:52:47 | 显示全部楼层
有可能是slim更新版本了。试试随书配套的slim模块
回复

使用道具 举报

132

主题

375

帖子

1181

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1181
发表于 2020-2-8 20:06:16 | 显示全部楼层
用这个附件中的slim模块。 03data.rar (1.46 MB, 下载次数: 135)
回复

使用道具 举报

132

主题

375

帖子

1181

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1181
发表于 2020-2-8 20:13:33 | 显示全部楼层
QQ图片20200208201035.png
从官方网站可以看到。compat是新加的。为了支持tf1.x中比较靠后的版本。1.13中没有这个compat所以报错。用以前的slim模块即可(在随书配套的资源里有,在附件里也有)。
回复

使用道具 举报

2

主题

5

帖子

38

积分

新手上路

Rank: 1

积分
38
 楼主| 发表于 2020-2-10 15:00:47 | 显示全部楼层
admin 发表于 2020-2-8 20:13
从官方网站可以看到。compat是新加的。为了支持tf1.x中比较靠后的版本。1.13中没有这个compat所以报错。用 ...

问题已解决,两个例子都已经跑通,谢谢大佬指导
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|大蛇智能 ( 京ICP备 18026897 号 )

GMT+8, 2020-9-28 01:06 , Processed in 0.035970 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表